Below are the minimum system requirements needed to use Composica. If you need any further information please view our FAQs or get in touch.

Minimum system requirements for Learners:
  • Browser: Internet Explorer 6 or higher, Firefox 3.0 or higher.*
  • OS: Any OS capable of running one of the abovementioned browsers, including Windows, Mac OS X, Linux, Android.
Minimum system requirements for Authors:
  • Browser: Internet Explorer 6.0 or higher.*
  • Authors can also use Composica right from the desktop, without having to use a browser.
  • Operating system: Windows.
Minimum server requirements:
  • CPU: 1GHz or higher.
  • RAM: 512MB or higher.
  • Operating system: Windows Server 2008 / Server 2003 / 7 Ultimate or better / Vista Ultimate or better / XP Pro, 32 or 64 bit.
  • Web Server: Internet Information Services (IIS) 5 or higher.
  • Database: SQL Server 2000 or higher, or MSDE / SQL Server Express 2005/2008 (does not require SQL Server license).

*Adobe Flash Player may or may not be required, depending on the features authors chose to use in each course. The following features require Flash: Mind Games, Shapes, FLV/MP3.

Bookmark and Share